Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted May 27, 2023 - 02:22 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 26, 2023 - 22:03 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 26, 2023 - 09:15 EDT
Scheduled
Update: time change
Today: May 26, 2023 at 9:30 pm EST Experience.com will make important updates to our domain infrastructure. The purpose is to enhance security and ensure the integrity of our domain.
During the migration process, there may be a temporary disruption in our XMP Platform. While we will make every effort to minimize any potential downtime, it is possible that some users may experience intermittent access issues during the transition. We apologize in advance for any inconvenience this may cause and appreciate your patience and understanding.