Encompass connection failing - March 11, 2022
Incident Report for Experience Management Platform
Resolved
After monitoring for several days, we conclude this issue is resolved.
Posted Mar 16, 2022 - 11:20 EDT
Monitoring
We will leave this incident in Monitoring Status for the next several days in case we see a repeat of the issue.
Posted Mar 11, 2022 - 07:30 EST
Identified
We have identified that 27 accounts were impacted on the first attempt.

20 were impacted on the 2nd attempt. 7 of the first 27 that failed, were successful on the second attempt.

Our engineers attempted a 3rd time and all 20 that had failed were successful.
Posted Mar 11, 2022 - 07:29 EST
Investigating
At approx. 3 am EST on Friday, March 11, 2022; Experience.com began to receive notifications of failed connections with Encompass for numerous clients who use Encompass as their system of record. This continued for about 45 minutes. There were about 17-20 campaigns impacted.

As per our protocol, the system automatically re-tried all failed connections again beginning at approx. 5 am EST. It appears most of those connections that failed earlier, failed again.

Engineers have been alerted and are investigating the cause of the data interruption.

It does not appear to be impacting all Experience.com clients that use Encompass and there appears to be no impact for clients that utilize other systems of record or deliver data via SFTP.

We will update the situation as information becomes available.

Impact Statement - for those clients that use Encompass as their LOS and deliver transaction data to Experience.com via the Encompass API connection it is possible we did not ingest any transaction data overnight from transactions that closed on March 10, 2022.

Actions you should take - You may submit a ticket to Support to let us know that surveys have not gone out for your company's campaign(s). We DO NOT recommend sending surveys manually because we anticipate rectifying the situation shortly.
Posted Mar 11, 2022 - 07:20 EST
This incident affected: API (Data).