Tier Managers Unable to See Users in the Tier they Manage
Incident Report for Experience Management Platform
Postmortem

Incident Report

Status: Resolved

Incident Summary

Region Tier Managers were unable to see Branch users in the Users tab of Hierarchy. 

Incident Description

Region Tier Managers were unable to see Branch users in the Users tab of Hierarchy, and therefore could not perform edit actions on them. However, these users could be seen under the Hierarchy tab for their respective branches. 

Incident Timeline

This incident spanned from ~March 16, 2022 at 1 AM EST to ~March 17, 2022 at 12:30 AM EST. 

Incident Impact

Region Tier Managers could not see and, therefore, take profile and permission actions on Branch users within the respective Region which they managed.

Root Cause

The temporary loss of visibility in the Users tab was caused by an unterminated string in the code. 

Remediation

Code updates have been made and deployed on March 17th, 2022.

Follow Up Actions

No follow up actions at this time. Some Region Managers may need to log out and log back in to see users.

Posted Mar 18, 2022 - 08:35 EDT

Resolved
As of 6:45 am EDT today (Thursday, March 17, 2022) - our Engineering Team has informed us that this issue has been resolved completely. Testing by Customer Support verifies this finding. Should you encounter this issue; please do not hesitate to submit a new Support Case by email to Support@Experience.com or via the compass icon in the upper right corner when you are logged into Experience.com
Posted Mar 17, 2022 - 11:21 EDT
Investigating
There have been several verifiable reports from clients that Tier Managers are unable to view all Users within their Tier(s). Our Support Crew has replicated the issue in a test account as well as witnessed it on screen sharing with customers. Due to the belief this issue is widespread and impacts Tier Managers' ability to deactivate and move Users, we have assigned this issue the highest priority as of 3/16/22 at 7:00 pm EDT. Our Engineers will be actively looking into the issue all night and we are optimistic to have an update in the morning.

If you are a Tier Manager and you are unable to view the Users in the branches under your management, please feel free to submit a case to the Concierge Customer Support Crew by email (support@experience.com). Please use subject : Tier Manager Unable to See Users. This may help us identify if this issue is more complex or widespread than we currently believe.
Posted Mar 16, 2022 - 19:53 EDT
This incident affected: API (Data).